Ich lerne Ruby on Rails for Africa

Railsとアフリカで苦戦するブログ

Seleniumがfirefoxと繋がらなくなった。

rubyで書いてたプログラムが突然動かなくなった。
Selenium webdriverがどうやらFirefoxと繋がらないらしい。

C:/Ruby193/lib/ruby/gems/1.9.1/gems/selenium-webdriver-2.29.0/lib/selenium/webdriver/firefox/launche
r.rb:79:in `connect_until_stable': unable to obtain stable firefox connection in 60 seconds


エラーメッセージはこんな感じ。



2013/02/19にFirefoxのver19.0にしたのが原因だった。(多分)
「Firefox 19」の正式版リリース プラグイン不要のPDFビューア追加


一応解決策としては

 gem install "selenium-webdriver"

ってコマンドプロンプトで打ち込んで、もう一度入れ直したら、無事動くようになりました。
結局、selenium次第ってことで良かったのかな?


一応エラー報告。誰かのお役に立てれば。