Ich lerne Ruby on Rails for Africa

Railsとアフリカで苦戦するブログ

You have already activated rake 10.1.0, but your Gemfile requires rake 10.0.3. Using bundle exec may solve this.

RailsでDBのマイグレーションを実行しようとしたときのこと。

rake db:migrate

とやると、以下のようなエラーメッセージが。

You have already activated rake 10.1.0, but your Gemfile requires rake 10.0.3. Using bundle exec may solve this.

まぁ、書いてあるように

bundle exec rake db:migrate

とやるとうまくはいったが、なんでこんなエラーが出るんだろ(´・ω・`)

bundle show

とやっても、rakeのバージョンは10.0.3だったしなぁ。

まぁ、とりあえずメモ。